Added details on debugging MLDonkey, namely /var/log/mldonkey.
Added explanation of telnet authentication.
MLDonkey is an open source, free software multi-network peer-to-peer application. Currently the following protocols are supported: eDonkey, Overnet, Bittorrent, Gnutella, Gnutella2, Fasttrack, FileTP and Kademlia.
I wanted to put my 266 Mhz Celeron to good use so I've decided to install MLDonkey without X11 support leaving only the core with both telnet and web interfaces.
Bellow are the steps needed to install MLDonkey on FreeBSD 7.0:
- % su
- # cd /usr/ports/net-p2p/mldonkey
- # make WITHOUT_GUI=yes WITHOUT_X11="YES" WITHOUT_TK="YES" install clean
- # rehash
- # echo 'mlnet_enable="YES"' >> /etc/rc.conf
- # echo 'mlnet_user="p2p"' >> /etc/rc.conf
- # echo 'mlnet_logfile="/var/log/mldonkey"' >> /etc/rc.conf
- # touch /var/log/mldonkey
- # chown p2p:p2p /var/log/mldonkey
- # pw user add p2p
- # mkdir /home/p2p
- # chown p2p:p2p /home/p2p
Now we are going to modify the MLDonkey configuration:
- % su
- # /usr/local/etc/rc.d/mlnet status
- # exit
- % telnet 127.0.0.1 4000
- > auth admin ""
- > passwd newpassword
- > set allowed_ips "127.0.0.1 192.168.1.0/24"
- > save
- > exit
In the future to authenticate through telnet:
- % telnet 127.0.0.1 4000
- > auth admin "mypasssword"
MLDonkey's web server can be accessed on http://localhost:4080, so fire-up your browser and point to the address. If your planning to access the server from another computer replace localhost bit by the server's ip or hostname.
The following are a few useful commands that can be passed on to MLDonkey:
- # /usr/local/etc/rc.d/mlnet start
- # /usr/local/etc/rc.d/mlnet stop
- # /usr/local/etc/rc.d/mlnet restart
- # /usr/local/etc/rc.d/mlnet status
2 comments:
Great tuto!!! Thanks a lot man!!
Thanks Alex.
I'm glad you liked :D
Post a Comment